Cross-Site Scripting Vulnerability in CKEditor 4 by CKSource
CVE-2021-33829

6.1MEDIUM

Key Information:

Vendor

Ckeditor

Status
Vendor
CVE Published:
9 June 2021

What is CVE-2021-33829?

A vulnerability in the HTML Data Processor of CKEditor 4 allows remote attackers to execute arbitrary JavaScript code via a specially crafted comment. This issue arises from improper handling of the sequence --!>, potentially leading to severe security implications for web applications using affected versions of CKEditor. Users are advised to update to version 4.16.1 or later to mitigate this risk.

References

CVSS V3.1

Score:
6.1
Severity:
MEDIUM
Confidentiality:
Low
Integrity:
Low
Availability:
Low
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
Required
Scope:
Changed

Timeline

  • Vulnerability published

  • Vulnerability Reserved

.