Stack-Based Buffer Overflow in QuickJS by QuickJS-ng
CVE-2024-13903
5.3MEDIUM
What is CVE-2024-13903?
A stack-based buffer overflow vulnerability exists in the QuickJS engine, affecting versions up to 0.8.0. The issue resides in the JS_GetRuntime function of quickjs.c, allowing attackers to exploit this weakness remotely. To mitigate risks associated with this vulnerability, it is crucial to upgrade to version 0.9.0, where the issue has been addressed with an official patch. Failure to apply this upgrade may expose systems to potential exploitation.
Affected Version(s)
QuickJS 0.1
QuickJS 0.2
QuickJS 0.3
