TinyMCE Fixes Cross-Site Scripting Vulnerability in Content Insertion Code
CVE-2024-29203

4.3MEDIUM

Key Information:

Vendor

Tinymce

Status
Vendor
CVE Published:
26 March 2024

What is CVE-2024-29203?

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content insertion code. This allowed iframe elements containing malicious code to execute when inserted into the editor. These iframe elements are restricted in their permissions by same-origin browser protections, but could still trigger operations such as downloading of malicious assets. This vulnerability is fixed in 6.8.1.

Affected Version(s)

tinymce < 6.8.1

References

CVSS V3.1

Score:
4.3
Severity:
MEDIUM
Confidentiality:
Low
Integrity:
None
Availability:
Low
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
Required
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

.