Improper Authorization Vulnerability in Apache ZooKeeper by Apache
CVE-2026-100252
What is CVE-2026-100252?
An improper authorization issue exists in Apache ZooKeeper where SASL authentication on the client port allows any requested authorization identity. Without proper validation against the authenticated principal, the server substitutes the requested identity with a canonical form but fails if no applicable rule is configured, leading to permission grants not intended for the client. This exposes a significant security risk, as an authenticated client can exploit this vulnerability to claim unauthorized identities and potentially gain superuser access depending on configured ACLs. It is crucial for users to upgrade to versions 3.8.8 or 3.9.7 to mitigate this risk.
Affected Version(s)
Apache ZooKeeper 3.9.0 <= 3.9.6
Apache ZooKeeper 3.8.0 <= 3.8.7
References
CVSS V4
Timeline
Vulnerability published
Vulnerability Reserved