Authentication Bypass Vulnerability in AiSOC by Beenuar
CVE-2026-103057
5.3MEDIUM
What is CVE-2026-103057?
A vulnerability exists in AiSOC versions 5.1.0 prior to 12.0.0 that allows attackers to bypass authentication on internal endpoints, including POST /internal/agent-event and POST /internal/push. This exploitation enables malicious actors to post fraudulent events with falsified tenant identifiers, potentially distributing harmful content through WebSocket and Redis SSE channels or sending unauthorized notifications to devices. Immediate attention and updates to AiSOC version 12.0.0 or later are recommended to mitigate the risks posed by this vulnerability.
Affected Version(s)
AiSOC 5.1.0 < 12.0.0
