Authentication Bypass Vulnerability in Apache Kylin Affects In-House Network Deployments
CVE-2026-108709

9.8CRITICAL

Key Information:

Vendor

Apache

Vendor
CVE Published:
16 October 2026

What is CVE-2026-108709?

An authentication bypass vulnerability exists in Apache Kylin that could allow unauthorized access to services if they are exposed to the public network. This issue primarily affects deployments of Apache Kylin versions 4.0.4 through 5.0.4. Organizations with in-house installations that remain isolated from external networks are less likely to be impacted. To mitigate this vulnerability, users are advised to upgrade to version 5.0.5, which includes necessary fixes to secure the environment.

Affected Version(s)

Apache Kylin 4.0.4 <= 5.0.4

References

CVSS V3.1

Score:
9.8
Severity:
CRITICAL
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

Credit

RunningSnail
.