Out-of-Bounds Read Vulnerability in ggml-org Whisper Model Loader
CVE-2026-110810

2.4LOW

Key Information:

Vendor

Ggml-org

Vendor
CVE Published:
15 October 2026

Badges

๐Ÿ‘พ Exploit Exists๐ŸŸก Public PoC

What is CVE-2026-110810?

The ggml-org whisper.cpp, prior to version 1.9.5, has a vulnerability in the whisper_model_load function which could lead to an out-of-bounds read. This occurs when manipulating the argument 'ttype' within the source file src/whisper.cpp. The exploit must start from a local environment, highlighting the need for users to upgrade to version 1.9.5 to mitigate risks. The vendor responsibly communicated and released a fixed version promptly, ensuring users have access to safe software.

Affected Version(s)

whisper.cpp 1.9.0

whisper.cpp 1.9.1

whisper.cpp 1.9.2

Exploit Proof of Concept (PoC)

PoC code is written by security researchers to demonstrate the vulnerability can be exploited. PoC code is also a key component for weaponization which could lead to ransomware.

References

CVSS V4

Score:
2.4
Severity:
LOW
Confidentiality:
None
Integrity:
None
Availability:
Low
Attack Vector:
Local
Attack Complexity:
Low
Attack Required:
None
Privileges Required:
Undefined
User Interaction:
Unknown

Timeline

  • ๐ŸŸก

    Public PoC available

  • ๐Ÿ‘พ

    Exploit known to exist

  • Vulnerability published

  • Vulnerability Reserved

Credit

Dem00000 (VulDB User)
VulDB CNA Team
.