Authentication Bypass Vulnerability in Apache Kafka Connect Admin REST API
CVE-2026-115644
What is CVE-2026-115644?
Apache Kafka Connect has a vulnerability that allows authentication bypass specifically in the admin REST API configuration when the 'admin.listeners' property is set separately from the main listeners property. This misconfiguration leads to the failure of security extensions to apply to endpoints accessed through the admin listener, resulting in potential unauthorized access. Attackers can exploit this to read logger configurations and manipulate logging levels, which could disrupt service operation and security monitoring. Users are advised to update to versions 4.2.2, 4.3.2, or 4.4.0, where security extensions are integrated into the admin listeners, or alternatively, to remove or unset the 'admin.listeners' configuration to mitigate risks.
Affected Version(s)
Apache Kafka 2.4.0 < 4.2.2
Apache Kafka 4.3.0 < 4.3.2