Denial of Service Vulnerability in Zip Library for Rust
CVE-2026-115909
7.5HIGH
What is CVE-2026-115909?
A vulnerability exists in the Zip library for Rust which allows attackers to exploit specific interactions with symbolic links during extraction. When creating a ZIP file with controlled uncompressed sizes, an attacker can induce an allocation request that triggers the process to abort. This results in repeated denial of service scenarios, impacting applications that utilize the ZipArchive::extract function. Users should upgrade to version 9.0.0 to mitigate this issue.
Affected Version(s)
zip2 >= 1.3.0, < 9.0.0
