Vulnerability in Open Neural Network Exchange Affecting Multiple Versions
CVE-2026-115921
6.2MEDIUM
What is CVE-2026-115921?
Open Neural Network Exchange (ONNX) versions 1.4.0 through 1.22.0 contain a vulnerability where the attributes required for the ScanInferenceFunction are not properly validated. This flaw can lead to dereferencing of a null pointer if certain attributes are missing, or oversized memory allocations when negative values are mishandled. Consequently, untrusted models can inadvertently disrupt shape inference processes, raising significant security concerns. This issue was resolved in version 1.22.0, encouraging users to update promptly.
Affected Version(s)
onnx >= 1.4.0, < 1.22.0
