TLS Certificate Vulnerability in MongoDB Shell Affects Node.js Runtime
CVE-2026-115930
7.6HIGH
What is CVE-2026-115930?
The MongoDB Shell (mongosh) contains a vulnerability stemming from its reliance on the Node.js runtime, which utilizes a potentially insecure TLS root certificate store. Specifically, it includes recoverable eMudhra intermediate CA certificates that can pose security risks. This issue affects versions of MongoDB Shell prior to 2.14.0. Users are strongly advised to update to mongosh 2.14.0, which includes a more secure version of Node.js (24.22.1 or later). If mongosh is installed via npm, ensure that the Node.js runtime is also updated separately to mitigate related risks.
Affected Version(s)
mongosh 0 < 2.14.0
