Credential Exposure in MLflow by Databricks
CVE-2026-116691
6.5MEDIUM
What is CVE-2026-116691?
A vulnerability in Databricks MLflow, an open-source AI engineering platform, allows for the exposure of sensitive credentials. Affected versions, from 2.19.0 until 3.17.0, fail to adequately sanitize nested credential-bearing values in the mlflow.crewai.autolog() function. Specifically, the Agent's llm field is converted to a string that can inadvertently include the provider API key. Furthermore, as the Agent object is expanded into mlflow.spanInputs, plaintext provider credentials can be sent to the MLflow trace backend or a configured OTLP destination, leaving them open to access by trace readers. Users are encouraged to upgrade to version 3.17.0 or later to mitigate this risk.
Affected Version(s)
mlflow >= 2.19.0, < 3.17.0
