Input Vulnerability in Highcharts JS Grid Pro by Highcharts
CVE-2026-116797
8.5HIGH
What is CVE-2026-116797?
Highcharts JS Grid Pro has a vulnerability where input renderers copy attributes from cells and edit mode elements using raw setAttribute calls. This allows attackers who control column configurations to inject event-handler attributes into rendered rows or controls, enabling scripts to execute within the context of the host page when users interact with inputs. The issue is resolved in Grid Pro version 3.2.0.
Affected Version(s)
dashboards >= 3.6.0, < 4.0.0
grid-pro >= 2.0.0, < 3.2.0
highcharts >= 2.0.0, < 3.2.0
