JavaScript Charting Library Vulnerability in Highcharts by Highsoft
CVE-2026-118248
6.9MEDIUM
What is CVE-2026-118248?
A vulnerability exists in Highcharts JS, a popular JavaScript charting library, whereby the editableOptions propertyPath segments can be manipulated without proper validation. This allows an attacker who has control over editableOptions to utilize prototype-related keys, potentially leading to the overwriting of values on Object.prototype. As a result, these modifications become accessible globally within the JavaScript context throughout the page. The issue has been resolved in version 4.2.2, highlighting the importance of upgrading to secure versions.
Affected Version(s)
dashboards >= 1.0.0, < 4.2.2
highcharts < 13.1.0
