Encoding Vulnerability in Echo Framework by Labstack
CVE-2026-118650
7.5HIGH
What is CVE-2026-118650?
The Echo framework by Labstack has an encoding vulnerability that emerges from a conflict in handling encoded request paths. Versions prior to 4.16.0 and 5.4.0 possess global middleware.Static instances that interpret encoded paths inconsistently. While the Echo router continues to match the encoded path, the static handler utilizes the decoded URL.Path. This inconsistency may give rise to unexpected file resolutions under the static root, thus compromising security in certain configurations. Upgrading to versions 4.16.0 or 5.4.0 effectively mitigates this issue.
Affected Version(s)
echo >= 5.0.0, < 5.4.0 < 5.0.0, 5.4.0
echo < 4.16.0 < 4.16.0
