Stack Buffer Overflow in psqlODBC Parser for PostgreSQL by PostgreSQL Inc.
CVE-2026-120061

7.5HIGH

Key Information:

Vendor

Postgresql

Status
Vendor
CVE Published:
2 November 2026

What is CVE-2026-120061?

The psqlODBC driver contains a vulnerability related to improper handling of ODBC escape sequences, where argument offsets are written to a fixed-size stack array without bounds checking and initialization. This oversight can lead to stack overflow when a {fn} escape includes an excessive number of arguments, allowing attackers to manipulate memory and potentially execute arbitrary code. Additionally, the vulnerability affects the copying of other escape sequence bodies, which can lead to further exploitation if untrusted SQL text is forwarded to the driver. It is crucial for users to update to version 18.00.0006 or later to mitigate this risk.

Affected Version(s)

psqlODBC 0 < 18.00.0006

References

CVSS V3.1

Score:
7.5
Severity:
HIGH
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
High
Privileges Required:
Low
User Interaction:
None
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

.