Cross Site Scripting Vulnerability in Typemill by Typemill
CVE-2026-120218
5.1MEDIUM
What is CVE-2026-120218?
A vulnerability exists in Typemill versions up to 2.26.0, specifically in the ControllerApiImage::saveImage function within the SvgSanitizer.php file. This flaw can allow remote attackers to execute cross site scripting attacks, potentially leading to unauthorized actions or data exposure. It is crucial to upgrade to Typemill version 2.27.0 to apply the necessary patch identified as 9ca43c4a7b6764c5a6ac11a2ccc099b036ee3cef.
Affected Version(s)
Typemill 2.0
Typemill 2.1
Typemill 2.2
References
CVSS V4
Score:
5.1
Severity:
MEDIUM
Confidentiality:
None
Integrity:
Low
Availability:
None
Attack Vector:
Network
Attack Complexity:
Low
Attack Required:
None
Privileges Required:
Undefined
User Interaction:
Unknown
Timeline
Vulnerability published
Vulnerability Reserved
Credit
fernando viana (VulDB User)
VulDB Vulnerability Moderation Team
