Denial of Service in CGI::Cookie for Perl by LEEJO
CVE-2026-120631
Currently unrated
What is CVE-2026-120631?
The CGI::Cookie component in Perl versions 4.67 to 4.99 is prone to a denial of service result due to the unsafe handling of the client cookie's expires value. The interpolation of this value into a regex pattern allows attackers to craft requests that can either lead the process to crash or to cause extensive backtracking, which effectively ties up system resources. This vulnerability can be exploited through specially formulated cookies, emphasizing the need for users to update to version 5.00 or later, where this issue has been addressed.
