Integer Overflow Vulnerability in imgproxy from the Vendor imgproxy
CVE-2026-123614
9.3CRITICAL
What is CVE-2026-123614?
imgproxy versions prior to 4.0.16 are susceptible to an integer overflow vulnerability within the ICO loader. This flaw allows remote attackers to manipulate the data_size parameter, potentially causing a heap buffer overflow. By submitting a specially crafted ICO image, attackers can corrupt heap memory, which may lead to process crashes or arbitrary code execution. Consequently, it is critical for users of imgproxy to upgrade to version 4.0.16 or later to mitigate this risk.
Affected Version(s)
imgproxy 4.0.0 < 4.0.16
imgproxy 4.0.16
