Permission Vulnerability in Kubescape by Kubernetes
CVE-2026-123665
2.4LOW
What is CVE-2026-123665?
A vulnerability has been found in Kubescape affecting versions up to 4.0.15, specifically in the GetWriter function within the Output component. This weakness arises from improper handling of the outputFile argument, potentially allowing local users to encounter permission issues. To mitigate this risk, it is advised to upgrade to version 4.0.16, which includes a significant patch (commit d90f77314c7d4f2b53cf2425844bde2315bd26d2). Ensuring that this software is kept up to date is critical for maintaining security.
Affected Version(s)
kubescape 4.0.0
kubescape 4.0.1
kubescape 4.0.2