Denial of Service Vulnerability in file-type by Sindressorhus
CVE-2026-31808
5.3MEDIUM
What is CVE-2026-31808?
A denial of service vulnerability was identified in the file-type library prior to version 21.3.1. This vulnerability is triggered by a crafted ASF (WMV/WMA) file input that contains a sub-header with a zero size field. The flawed parser enters an infinite loop when processing this type of input, effectively stalling the Node.js event loop and rendering applications unresponsive. An attacker can exploit this vulnerability by providing a specific 55-byte payload, causing a repeated read of the corrupted data. Users are encouraged to upgrade to version 21.3.1 or later to mitigate this issue.
Affected Version(s)
file-type >= 13.0.0, < 21.3.1
