Wails Framework Desktop Applications Vulnerability in Go and Web Technologies
CVE-2026-34157
7.6HIGH
What is CVE-2026-34157?
The Wails framework allows desktop application development using Go and web technologies but has a vulnerability related to wildcard patterns in the origin validator. Versions 2.0.0 to 2.12.0 allow unauthorized access through improperly configured wildcard origins, enabling potential attackers to exploit IPC mechanisms. This may lead to unauthorized execution of exposed methods and pose risks to the confidentiality, integrity, and availability of sensitive data and operations. Users should upgrade to version 2.13.0 to mitigate these risks.
Affected Version(s)
wails >= 2.0.0, < 2.13.0
