Arbitrary Code Execution and SQL Injection Vulnerability in Elo Language
CVE-2026-44265

7.4HIGH

Key Information:

Vendor

Enspirit

Status
Vendor
CVE Published:
3 November 2026

What is CVE-2026-44265?

The Elo expression language, utilized in no-code tools, has a vulnerability due to its programmatic AST API allowing unvalidated inputs from varying sources like JSON and plugin outputs. This oversight enables crafted inputs to be evaluated as executable code, creating paths for arbitrary code execution in JavaScript, Ruby, and Python environments, along with SQL injection risks. The vulnerability affects specific fields, including int_literal / float_literal values, variable names, and others. Users should upgrade to version 1.0.1 to mitigate these risks effectively.

Affected Version(s)

elo < 1.0.1

References

CVSS V3.1

Score:
7.4
Severity:
HIGH
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Local
Attack Complexity:
High
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

.