Unauthenticated AgentOS in PraisonAI Affects Multiple Versions
CVE-2026-57116
What is CVE-2026-57116?
The PraisonAI AgentOS, integral to multi-agent teams, contains a significant security flaw that permits unauthenticated access to its FastAPI deployment. Present in versions 4.2.1 through 4.6.58, this vulnerability allows unauthorized clients to execute agent functionality without proper authentication. The chat route specifically calls agent.chat(request.message), which can be exploited by sending incorrectly formed bearer tokens or no authentication at all. This vulnerability poses risks beyond mere metadata disclosure, as an unprotected client can interact with the agents, leveraging sensitive context, memory, or API integrations. It’s crucial for users to upgrade to version 4.6.59 or later to mitigate the risk associated with this issue. For further details and the official patch, refer to the security advisory linked below.
Affected Version(s)
PraisonAI >= 4.2.1, < 4.6.59
