Privilege Escalation Vulnerability in Asterisk Telephony Toolkit
CVE-2026-57203
6.9MEDIUM
What is CVE-2026-57203?
Asterisk, an open-source telephony toolkit, suffers from a privilege escalation vulnerability when the ast_loggrabber executes a Python script from the world-writable /tmp directory. This flaw allows an attacker, who has secured a shell session on the Asterisk server, to place a malicious script in the /tmp folder. If an administrator runs ast_loggrabber with elevated privileges, the malicious script can be executed, enabling the unauthorized elevation of privileges. The issues have been patched in versions Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1, and their certified counterparts.
Affected Version(s)
asterisk < 20.20.1 < 20.20.1
asterisk >= 21.0.0-pre1, < 21.12.3 < 21.0.0-pre1, 21.12.3
asterisk >= 22.0.0-pre1, < 22.10.1 < 22.0.0-pre1, 22.10.1
