Arbitrary Code Execution in Functype Libraries by Functype Vendor
CVE-2026-59176

7.8HIGH

Key Information:

Status
Vendor
CVE Published:
28 October 2026

What is CVE-2026-59176?

The functype-mcp-server before version 1.4.4 has a vulnerability in its set_functype_version tool, which allows attackers to craft a malicious version string that could lead to the installation of arbitrary local or remote packages. This exploitation provides a pathway for executing attacker-controlled JavaScript with the privileges of the MCP server process. The insecure implementation is exacerbated by the tool being enabled by default without authentication when in stdio mode. Furthermore, the vulnerability can also be triggered indirectly via a connected AI assistant. This risk escalates when the MCP server is exposed in environments using TRANSPORT_TYPE=httpStream, potentially allowing attackers remote access without needing local credentials. The flaw has been resolved in version 1.4.4.

Affected Version(s)

functype < 1.4.4

References

CVSS V3.1

Score:
7.8
Severity:
HIGH
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Local
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
Required
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

.