Missing Authorization Vulnerability in Apache Kylin by Apache
CVE-2026-63619
9.1CRITICAL
What is CVE-2026-63619?
Apache Kylin exhibits a vulnerability due to insufficient authorization within its backend metadata dump API. This flaw primarily affects Kylin services that are directly exposed to the public network, posing risks in these scenarios. Most on-premise Kylin deployments should remain unaffected. The issue is present in Kylin versions from 4 up to 5.0.4, and it is highly recommended for users to upgrade to version 5.0.5, which addresses this vulnerability.
Affected Version(s)
Apache Kylin 4..0.0 <= 5.0.4
References
CVSS V3.1
Score:
9.1
Severity:
CRITICAL
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged
Timeline
Vulnerability published
Vulnerability Reserved
Credit
"George Chen" <http://github.com/geo-chen>
n0mi1k Security
MopMonk-AI