Improper Certificate Validation in Dell System Update
CVE-2026-63697
7.6HIGH
What is CVE-2026-63697?
Dell System Update prior to version 2.3.0.0 is susceptible to an improper certificate validation vulnerability. This issue allows an attacker with high privileges and remote access to potentially exploit the flaw, facilitating remote execution capabilities that could compromise system integrity.
Affected Version(s)
System Update 0 < 2.3.0.0 or later
References
CVSS V3.1
Score:
7.6
Severity:
HIGH
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
High
Privileges Required:
High
User Interaction:
Required
Scope:
Changed
Timeline
Vulnerability published
Vulnerability Reserved
Credit
Dell would like to thank Ori Gabriel for reporting these issues.