Deserialization Vulnerability in Apache Kylin by Apache
CVE-2026-64610

9.8CRITICAL

Key Information:

Vendor

Apache

Vendor
CVE Published:
16 October 2026

What is CVE-2026-64610?

A vulnerability in Apache Kylin allows for unsafe Java deserialization due to a flaw in the external cache service. This can lead to severe security risks, including potential unauthorized access to sensitive data. Affected versions include Apache Kylin from 4 up to 5.0.4. Users are advised to upgrade to version 5.0.5, which addresses this vulnerability and enhances overall system security.

Affected Version(s)

Apache Kylin 4..0.0 <= 5.0.4

References

CVSS V3.1

Score:
9.8
Severity:
CRITICAL
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

Credit

Andrew Ridings <ridingsa@gmail.com>
.