SQL Injection Vulnerability in Apache Kylin by Apache
CVE-2026-64959
9.8CRITICAL
What is CVE-2026-64959?
An SQL injection vulnerability has been identified in Apache Kylin versions 5.0.0 to 5.0.4, specifically affecting certain backend cache APIs that lack necessary authentication. This flaw can allow unauthorized execution of injected SQL commands if the Kylin services are directly exposed to the public network, which is less common in most in-house deployments. To mitigate this vulnerability, it is crucial for users to upgrade to version 5.0.5, which includes the necessary fixes.
Affected Version(s)
Apache Kylin 5.0.0 <= 5.0.4
References
CVSS V3.1
Score:
9.8
Severity:
CRITICAL
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged
Timeline
Vulnerability published
Vulnerability Reserved
Credit
zx (Jace) <g.mygenie@gmail.com>
baozongwi <baozongwi@qq.com>
chennbnbnb