Improper Authentication Vulnerability in Apache Kylin
CVE-2026-68573

9.8CRITICAL

Key Information:

Vendor

Apache

Vendor
CVE Published:
16 October 2026

What is CVE-2026-68573?

An improper authentication vulnerability exists in Apache Kylin, allowing unauthenticated users to access sensitive system cleanup actions. This poses a significant risk to Kylin services exposed to public networks, although typical in-house deployments remain largely unaffected. To mitigate this risk, users are advised to upgrade to version 5.0.5, which addresses the issue effectively.

Affected Version(s)

Apache Kylin 4.0.0 <= 5.0.4

References

CVSS V3.1

Score:
9.8
Severity:
CRITICAL
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

Credit

Fabian Fleischer
MopMonk-AI
Wanxin Yin
.