API Vulnerability in Chartbrew Web Application
CVE-2026-68935
What is CVE-2026-68935?
Chartbrew, an open-source web application designed to create charts from databases and APIs, experiences an issue in versions 4.8.5 through 5.2.2. The application allows authenticated users with permissions to manage API connections to manipulate the internal allowPrivateHost field via user input. This manipulation can lead to the bypassing of private and reserved network restrictions on API connections, enabling unauthorized requests to internal HTTP services accessible from the Chartbrew server. Such exploitation may result in information disclosure or unauthorized actions depending on the affected service. Notably, recognized cloud metadata endpoints are still secured and remain blocked. Users are advised to upgrade to version 5.2.3 to mitigate this vulnerability.
Affected Version(s)
chartbrew < 5.2.3
