Unauthorized Job Manipulation Vulnerability in Apache Kylin
CVE-2026-69077

7.5HIGH

Key Information:

Vendor

Apache

Vendor
CVE Published:
16 October 2026

What is CVE-2026-69077?

This vulnerability in Apache Kylin allows unauthorized manipulation of jobs across projects, posing a significant risk to services exposed to public networks. Although it primarily impacts those deployments directly accessible over the internet, most in-house installations are less affected. Users are strongly advised to upgrade to version 5.0.5 or later to remediate this issue and ensure the integrity of their data processing environments.

Affected Version(s)

Apache Kylin 4..0.0 <= 5.0.4

References

CVSS V3.1

Score:
7.5
Severity:
HIGH
Confidentiality:
High
Integrity:
None
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

Credit

Harry <h9408400@gmail.com>
.