SQL Exposure in Apache Kylin Affects Multiple Versions
CVE-2026-69080
7.5HIGH
What is CVE-2026-69080?
A vulnerability has been identified in Apache Kylin that allows unauthorized actors to gain exposure to sensitive SQL Black List data. This affects users running versions 4.x through 5.0.4 of the product. To protect against potential risks, it is strongly advised that users upgrade to Apache Kylin version 5.0.5, which implements necessary security fixes.
Affected Version(s)
Apache Kylin 4..0.0 <= 5.0.4
References
CVSS V3.1
Score:
7.5
Severity:
HIGH
Confidentiality:
High
Integrity:
None
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
None
User Interaction:
None
Scope:
Unchanged
Timeline
Vulnerability published
Vulnerability Reserved
Credit
Haoran Zhao, Yicheng Yu, and Lei Zhang (System and Software Security Lab in Fudan University)
Yan Xu