Missing Authorization in Apache Wicket - Affected Versions and Vendor Details
CVE-2026-82704

6.9MEDIUM

Key Information:

Vendor

Apache

Vendor
CVE Published:
1 November 2026

What is CVE-2026-82704?

The vulnerability in Apache Wicket arises from a failure in the authorization checks, allowing unauthorized listeners to be invoked under certain conditions. When an IRequestListener is triggered without a page identifier, the visibility and enabled state flags do not get updated properly. This can occur on both stateful and stateless pages, where the authorization strategy does not effectively prevent the execution of component listeners that should be restricted, potentially exposing sensitive functionality. This issue impacts versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0, urging users to upgrade to the fixed versions 8.20.0, 9.25.0, or 10.12.0.

Affected Version(s)

Apache Wicket 8.0.0 <= 8.19.0

Apache Wicket 9.0.0 <= 9.24.0

Apache Wicket 10.0.0 <= 10.11.0

References

CVSS V4

Score:
6.9
Severity:
MEDIUM
Confidentiality:
None
Integrity:
Low
Availability:
None
Attack Vector:
Network
Attack Complexity:
Low
Attack Required:
None
Privileges Required:
Undefined
User Interaction:
None

Timeline

  • Vulnerability published

  • Vulnerability Reserved

Credit

Emond Papegaaij
.