Authorization Flaw in Apache OFBiz Affects Multiple Versions
CVE-2026-84183

8.8HIGH

Key Information:

Vendor

Apache

Vendor
CVE Published:
5 November 2026

What is CVE-2026-84183?

An incorrect authorization vulnerability in Apache OFBiz allows a remote authenticated attacker with limited permissions to execute arbitrary commands as the OFBiz process user. This is achieved through a flaw in the updateLayout method, where the authorization check inadequately validates permissions against the intended Content record. As a result, an attacker can manipulate existing content records, leading to security breaches. It is advisable for users to upgrade to version 24.09.08 to remediate this issue.

Affected Version(s)

Apache OFBiz 0 < 24.09.08

References

CVSS V3.1

Score:
8.8
Severity:
HIGH
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
Low
User Interaction:
None
Scope:
Unchanged

Timeline

  • Vulnerability published

  • Vulnerability Reserved

Credit

Jonah Burgess (CryptoCat)
Krishna Uprit
.