XML External Entity Reference Vulnerability in Apache Camel Saxon Component
CVE-2026-90885
7.5HIGH
What is CVE-2026-90885?
A vulnerability exists in the Apache Camel Saxon component where improper handling of XML External Entities enables an attacker to exploit the system. The default Saxon configuration lacks restrictions, allowing external DOCTYPE declarations and entities to be resolved upon parsing. This flaw may permit untrusted XML payloads to read sensitive files on the server and initiate unwanted network requests. Users are advised to upgrade to version 4.23.0 or, if on earlier supported streams, to 4.22.2 or 4.18.5 to mitigate this vulnerability. For those unable to upgrade immediately, caution is advised in evaluating untrusted XML over certain message body types.
Affected Version(s)
Apache Camel 4.0.0 < 4.18.5
Apache Camel 4.19.0 < 4.22.2