Authorization Flaw in Neo4j GraphQL for Data Protection
CVE-2026-92682
8.6HIGH
What is CVE-2026-92682?
A vulnerability in Neo4j's GraphQL library affects versions from 7.0.0 up to 7.6.3, causing authorization filters to incorrectly handle 'none' quantifiers. This misconfiguration allows authenticated users to access sensitive records that should be restricted based on their permissions, potentially exposing or allowing unauthorized mutations of crucial data. The issue is resolved in version 7.6.4, where the filtering logic has been corrected to ensure proper authorization checks.
Affected Version(s)
@neo4j/graphql 7.0.0 < 7.6.4
