Input Validation Vulnerability in Apache ActiveMQ Impacting LDAP Authorization
CVE-2026-108500

Currently unrated

Key Information:

Vendor

Apache

Vendor
CVE Published:
4 November 2026

What is CVE-2026-108500?

An input validation vulnerability exists in Apache ActiveMQ when configured with the LDAPAuthorizationMapPlugin. This flaw permits an authenticated attacker to create or access a destination with a specially crafted name that includes LDAP DN special characters, such as comma, plus, equals, or backslash. This manipulation compromises the LDAP search base used for access control list (ACL) checks. Users are advised to promptly upgrade to version 6.4.0, 6.3.3, or 5.19.12 to mitigate this issue.

Affected Version(s)

Apache ActiveMQ 6.3.0 < 6.3.3

Apache ActiveMQ 5.19.0 < 5.19.12

Apache ActiveMQ 6.4.0

References

Timeline

  • Vulnerability published

  • Vulnerability Reserved

Credit

Rishabh Soni (Azmendus) <rishabhv704@gmail.com>
.