Shortcode Injection Vulnerability in My Calendar Plugin by WordPress
CVE-2026-119714
6.9MEDIUM
What is CVE-2026-119714?
The My Calendar plugin for WordPress prior to version 3.8.11 is susceptible to a shortcode injection flaw. This vulnerability allows unauthenticated attackers to exploit the mcs search parameter, executing registered shortcodes without proper validation. When a GET request is made with the mcs value, it is processed in the mc_search_results() function without the necessary bracket encoding, enabling potential content injection and spoofing across any page or post. Users are encouraged to update to version 3.8.11 or later to mitigate this risk.
Affected Version(s)
My Calendar - Accessible Event Manager 3.8.8 < 3.8.11
References
CVSS V4
Score:
6.9
Severity:
MEDIUM
Confidentiality:
Low
Integrity:
Low
Availability:
None
Attack Vector:
Network
Attack Complexity:
Low
Attack Required:
None
Privileges Required:
Undefined
User Interaction:
None
Timeline
Vulnerability published
Vulnerability Reserved
Credit
Andres Poulin Mateos (Drakon Tech Solutions SLU)
joedolson