Expression Language Injection Vulnerability in Apache OFBiz EmailServices
CVE-2026-82912
8.8HIGH
What is CVE-2026-82912?
A vulnerability exists in the EmailServices component of Apache OFBiz versions prior to 24.09.08, allowing remote authenticated users with specific permissions (OFBTOOLS_VIEW and ACCOUNTING_VIEW) to execute arbitrary operating system commands. This is achieved by injecting a Groovy expression into the email body or subject during invoice processing, as the Send Per Email function inadequately validates user input. The vulnerability stems from the use of FlexibleStringExpander.expandString, which executes embedded Groovy code without proper security checks, putting systems at risk. Users are advised to upgrade to version 24.09.08 to mitigate this vulnerability.
Affected Version(s)
Apache OFBiz 0 < 24.09.08
References
CVSS V3.1
Score:
8.8
Severity:
HIGH
Confidentiality:
High
Integrity:
High
Availability:
High
Attack Vector:
Network
Attack Complexity:
Low
Privileges Required:
Low
User Interaction:
None
Scope:
Unchanged
Timeline
Vulnerability published
Vulnerability Reserved
Credit
Bartlomiej Dmitruk at striga.ai
Ve1ledJustice
Krishna Uprit